Fork me on GitHub
0%

PAT甲级1006

Question

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output

SC3021234 CS301133

Thinking

时间哈希

code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
//
// PAT甲级1006.cpp
// Fushi
//
// Created by H C on 2021/2/6.
//

#include <stdio.h>
#include <cstring>
using namespace std;

int main()
{
int N;
char id[16];
char earid[16];
char lateid[16];
int eartime = 86400;
int latetime = 0;
scanf("%d",&N);
// scanf后面如果接
// getchar();
while (N--) {
int h1,m1,s1,h2,m2,s2;
// 不能用gets 不然把后面的数字也读到字符数组里了
scanf("%s %d:%d:%d %d:%d:%d",id,&h1,&m1,&s1,&h2,&m2,&s2);
int tmp1 = 3600*h1+m1*60+s1;
int tmp2 = 3600*h2+m2*60+s2;
if(tmp1<eartime) {eartime = tmp1;strcpy(earid,id);}
if(tmp2>latetime) {latetime = tmp2;strcpy(lateid,id);}
}
printf("%s %s",earid,lateid);
}

觉得有帮助的请作者喝杯咖啡吧~