Fork me on GitHub
0%

PAT甲级1009多项式相乘

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

题目大意

给出两个多项式A和B,求A*B的结果

注意

错因:c开了1010。应该开2000+
方法:用数组下标作为幂次,用数组元素存储系数

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
//
// PAT 甲 1009多项式乘积.cpp
// Fushi
//
// Created by H C on 2021/2/5.
// 题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805509540921344

// 错因:c开了1010。应该开2000+
// 方法:用数组下标作为幂次,用数组元素存储系数

#include <stdio.h>
using namespace std;

double a[1010]={0};
double b[1010]={0};
double c[2010]={0};

int main()
{
int K1,K2;
scanf("%d",&K1);
while (K1--) {
int N;
double A;
scanf("%d %lf",&N,&A);
a[N] = A;
}
scanf("%d",&K2);
while (K2--) {
int N;
double B;
scanf("%d %lf",&N,&B);
b[N] = B;
}
int count=0;
for (int i=0; i<1010; i++)
{
if (a[i]!=0) {
for(int j=0; j<1010; j++)
{
if(b[j]!=0) {c[i+j] += a[i]*b[j];}
}
}
}
for (int i=2010; i>=0; i--) {
if(c[i]!=0) count++;
}
printf("%d",count);
for (int i=2010; i>=0; i--) {
if (c[i]!=0) {
printf(" %d %.1lf",i,c[i]);
}
}
}
觉得有帮助的请作者喝杯咖啡吧~